New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Sound cuts out during online match of Unspoken/Dead and Buried

edwardburch3edwardburch3 Posts: 6
NerveGear
My Rift audio worked totally fine during the entire tutorial for both games. It also works during practice rounds and in menus. But right when I make a connection to another player in any online mode, the sound cuts out. Just silence. If I hit the Home button, it blips in for a split second. If I exit to home, everything works again. Even if I play through the match silently, the instant the other player disconnects my sound comes back. 

I've added exceptions to my firewall, thinking that could be it. Still hasn't changed. Does anyone know whats happening? 

Comments

  • edwardburch3edwardburch3 Posts: 6
    NerveGear
    I've been messing around, and I found that if I use windows to disable the Rift microphone, the audio doesnt cut out during online matches. Of course, then I can't communicate with other players.
  • CSPhobosCSPhobos Posts: 1
    NerveGear
    Make sure in your Communications tab of the Windows Sound/Playback Devices control panel is set to "do nothing" during communications activity. 
  • edwardburch3edwardburch3 Posts: 6
    NerveGear
    edited December 2016
    Tried this, didn't work. I also played around with 'Exclusive Mode' on the Rift mic in Windows, I unplugged one of the Rift Sensors thinking it could be a bandwidth issue. Nothing.

    I guess I'll uninstall/reinstall Oculus next. 
  • edwardburch3edwardburch3 Posts: 6
    NerveGear
    Still not giving up! I did a fresh install of Oculus, did nothing.

    Moved the USBs around a lot, tried pretty much every combination possible. Even put the Rift on a USB2.0. I initially thought this was working, but it turned out that it just automatically disabled the mic, which from my previous experiment allows audio to pass through. 

    Tried updating my USB drivers, no dice. 

    Tried setting the Rift mic as the default in windows, and then in the Oculus software, choosing to use the Windows Default device. Nada.
  • parabolic606parabolic606 Posts: 2
    NerveGear
    Same here 
  • elbofforelboffor Posts: 2,303 Valuable Player
    Using extention cables by any chance?
    This is my forum signature.
    There are many others like it, but this is mine.
  • parabolic606parabolic606 Posts: 2
    NerveGear
    edited December 2016
    No extension cables
  • edwardburch3edwardburch3 Posts: 6
    NerveGear
    I am only use one extension cable, just a 6ft CableMatters USB3.0 for one of the sensors. 
  • marwood82marwood82 Posts: 14
    NerveGear
    same problem here. i'm using a hdmi+usb extension for the rift. this happened a bit a while ago on other games then seemed to stop. but its back again now. i notice if i switch the rift headphones off and use my own wireless set then it works fine. i only get sound drop out when sending sound direct to the rift
  • OmiCron07OmiCron07 Posts: 3
    NerveGear
    edited December 2016
    I have exactly the same problem! Whenever it's a multiplayer game using the microphone, the audio stops working. I have the Rift since launch and the problem only started with the arrival of Touch. Tried with and without the extensions. I can make it "working" but people says my voice is really weird, like low deep god like and can't hear me well.

    My solution, not a good one, is using Microsoft's generic drivers for the audio of the Rift. I can get the sound working in multiplayer game but doesn't sound great for the mic. If I reinstall the Oculus' drivers, the same problems come back. I don't give the steps because it's not a good solution and making the mic unusable, then just disable Rift mic in the recording devices panel instead.

    Or for a temporary solution, while in-game and each game you start, go to recording devices panel, right click on the Rift mic, disable, enable it again, change tab or close the panel. You will have sound while the mic is usable but I don't know if sound great.

    The strange thing is, when you disable and enable again the mic, you have no sound until you switch the tab. If you switch back to the recording panel, the sound cut out again.
  • OmiCron07OmiCron07 Posts: 3
    NerveGear
    Someone at Oculus can respond to let us know if the problem is investigated?
  • theboyrobertstheboyroberts Posts: 1
    NerveGear
    Exactly the same issue.

    Would rather play the game with sound and no voice chat though - any ideas how I can do that?
  • OmiCron07OmiCron07 Posts: 3
    NerveGear
    Exactly the same issue.

    Would rather play the game with sound and no voice chat though - any ideas how I can do that?
    Disable the mic in recording devices. But I fixed my problem switching the USB port for the headset.
  • SuperTuckSuperTuck Posts: 119
    Art3mis
    Removing any USB and hdmi extension fixed my problem
  • LionheartcartoonLionheartcartoon Posts: 2
    NerveGear
    I use no cord extensions and sadly connecting the headset to a different USB3 port is not an option.  Currently on an Asus P8z77 -V Deluxe and the ASMedia USB 3 ports cause the cameras to not be properly detected.

    As with the other users, Dead and Buried works great up till the point I join and online game, where the sound cuts off.  The speaker icon DOES show that the microphone is picking up sounds, but I don't hear anything or have any way to know if someone hears what is broadcasted. 

    I can only imagine the nightmare the other players went through, trying to talk to me or tell whoever they could hear to shut up.  Especially if they could hear something, as I always assumed that no one could hear anything if I couldn't hear it.

    Looks like my best option is to disable the mic as to prevent said bug.
  • cyberealitycybereality Posts: 22,775 Oculus Staff
    edited March 20
    Rift can be used on a USB 2.0 port and sometimes this helps with compatibility.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • TheseGoodTartsTheseGoodTarts Posts: 1
    NerveGear
    Try going to playback devices. Select Headphones (Rift Audio). Click on Properties. Then open the Advanced tab, and make sure the Default Format is set to "2 channel, 16 bit, 44100 Hz (CD Quality)". For me, it was set to 48000 Hz for some reason.

    I had this problem for a long time. This fixed it for me.

    If that doesn't work I'd say just fuck around with the settings. Maybe when you set it up, you (or someone else) switched something from default. If you want to know the exact settings that worked for me, just ask.
  • ElecmanElecman Posts: 129
    Hiro Protagonist
    Same problem here.
  • ExcellionExcellion Posts: 1
    NerveGear
    Try going to playback devices. Select Headphones (Rift Audio). Click on Properties. Then open the Advanced tab, and make sure the Default Format is set to "2 channel, 16 bit, 44100 Hz (CD Quality)". For me, it was set to 48000 Hz for some reason.
    Cheers, this worked for me.

    In VRChat it was even weirder. Since you can change the input device type (mic), whenever I switched to my main (non-oculus) sound device for recording, the sound from the oculus speakers started working again. The output of the sound is definitely linked to the mic being active/selected or not.
  • diehard25259diehard25259 Posts: 1
    NerveGear
    I had all of these symptoms.  I was losing all sound in multiplayer atmospheres, and could not get audio in Bigscreen and even the Oculus video app.  I was also able to recreate/fix the symptoms as described above by disabling the rift mic and switching tabs to get sound back.  I was not using any extensions, and all three USBs (sensors x2 and headset x1) were in USB 3.0 ports.  After hours of messing with this problem,reinstalling drivers, etc., it was TheseGoodTarts's solution that fixed it. Switching the playback format of the rift audio headphones to "2 channel, 16 bit, 44100 Hz (CD Quality)" - instead of 48000 Hz completely fixed the issue.  

    Thank you, TheseGoodTarts!!!!!
Sign In or Register to comment.