New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Only one sensor listed under devices in the Oculus software

WebMaximusWebMaximus Posts: 43
Lawnmower Man (or Woman)
Is it normal that only one sensor is listed under devices in the Oculus software when you have two of them installed, one for the Rift headset and one for the Touch controllers? Yet both of them are listed with status OK in Windows Device Manager.

Here's a screenshot what it looks like.


Comments

  • WebMaximusWebMaximus Posts: 43
    Lawnmower Man (or Woman)
    So I found out on my own of course it's not normal to only have one sensor showing up like in my example above but normally both sensors will show up.

    What I've found after some testing is I can make both sensors show up 10 out of 10 times by unplugging the sensors physically and then plug them in again. I also found that sometimes no sensors will be seen in the Oculus software under the Devices section and then of course I will be notified of this problem with no sensor recognized.

    To me it looks like some kind of timing issue where the sensors try to start before Windows is fully ready or do you guys have any other ideas? I was thinking if there's a way to force a delay for a USB device and if that might solve the problem to have the sensors load maybe 30 seconds after Windows logon or something like that. Haven't find a way to accomplish that though.

    What is very strange is why the sensors show up as green with the status 'This device is working properly' looking in Windows Device Manager even when they are not listed in the Oculus Software. That might indicate the problem really isn't with the sensors or the USB connection but rather with the Oculus software.

    I wonder if the problem could be some parts of the Oculus software load before the sensors have been loaded/connected. That would of explain why the sensor(s) don't show up in the Oculus software.

    Am I the only one in here with this problem considering the silence so far?
  • cyberealitycybereality Posts: 22,420 Oculus Staff
    Could be a USB issue. Have you tried switching USB ports for the sensors? Also, this add-on card may help.
    https://www.amazon.com/Inateck-Superspeed-Ports-PCI-Expansion/dp/B00B6ZCNGM
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • WebMaximusWebMaximus Posts: 43
    Lawnmower Man (or Woman)
    Nothing wrong with my USB ports. I've used OculusCompatCheck.exe which reports all part of my system including my USB 3 ports are fine. I've also tried switching USB ports but still same problem.

    However I'm happy to say I think I just found the culprit and just like I suspected it was part of the Oculus software is started before Windows had the chance to fully recognize and initialize the Rift sensors/USB ports the sensors are connected to.

    More exactly it's the service called OVRService with display name Oculus VR Runtime Service that is automatically started too early before the sensors have been discovered during the boot process. Changing the startup mode for this service from 'Automatic' to 'Automatic (Delayed Start)' adds a default 120 seconds delay before the service is started and this solves my problem. Having the service set like this my sensors show up correctly in the Oculus software 10 out of 10 times.

    The back of this coin is you'll have to wait for 120 seconds before you can start using your Rift headset since you won't be able to launch the Oculus software until this service is running but that is probably a cheap price to pay to have your sensors work correctly.

    Also there should be a way to shorten the 120 seconds by following the below instruction found over at MS Technet. Haven't tried it out myself yet though.

    With regedit, look into the registry key of the service.

    When the startup type of the service is set to "Automatic (Delayed start)", the value of DelayedAutostart is set to 1
    HKLM\SYSTEM\CurrentControlSet\services\<service name>\DelayedAutostart

    To increase the default delay of 120 seconds, right click the registry key and add new key AutoStartDelay (DWORD (32-bit)     
    HKLM\SYSTEM\CurrentControlSet\services\<service name>\AutoStartDelay
    Its value can be set to decimal 240 for example.
  • cyberealitycybereality Posts: 22,420 Oculus Staff
    Interesting. I haven't heard of that before but sounds plausible. Thanks for sharing.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • WebMaximusWebMaximus Posts: 43
    Lawnmower Man (or Woman)
    The method described above worked just fine until I moments ago received a message in the Oculus software telling me a firmware update for my sensors was available.

    I hesitated thinking to myself 'This sounds dangerous' but in the end I do want to be on the latest version for any firmware or software I use so I went ahead with the upgrade which finished successfully. What wasn't equally successful was after the upgrade only one of my sensors showed in the Oculus software in the very same way as when my problem started before finding this method to use a delayed startup of the Oculus service mentioned in my previous post.

    Thought to myself hopefully it will be OK if I restart my computer but nope...now I'm back to square one with only one of my two sensors detected even with the service set to delayed start.

    I'm also in contact with Oculus support and they asked me all the normal stuff such as running the compatibility tool, make sure to use USB ports on the back of my computer, try different USB ports, reinstall the Oculus software etc etc but I've already been through all that before to no avail.

    Getting rather frustrated to be honest. This is the second pair of Oculus Rift glasses I bought and this time I also got the Touch controllers. The first time I returned the glasses for various reasons where the issues with the Oculus software/drivers and the intermittent USB issues were part of my decision to bring them back. However the "problem" with VR is once you tried it a normal 2D screen isn't that fun anymore so that's why I ended up giving Oculus a second chance.

    I really do want to solve my problems this time around because even if I could return my devices again that will only leave me in the same situation again where I'm missing the VR immersion. I guess the best thing I could do at this point is to provide any logs and other stuff Oculus will ask for and in the end I hope this will help them help me solve this problem once and for all.
  • WebMaximusWebMaximus Posts: 43
    Lawnmower Man (or Woman)
    ...and with some luck I just might have been able to fix the problem again by physically unplugging both sensors and then reconnecting them.

    So far so good and I'll keep my fingers crossed it will stay like this!
  • WebMaximusWebMaximus Posts: 43
    Lawnmower Man (or Woman)
    Just wanted to add for anyone else having the same issue that although things are working really good now most of the time it still happens Oculus software tells me it can't find my sensors. When that happens it's normally easily fixed by restarting the Oculus VR Runtime Service and then both sensors show up just fine again.

    Hopefully Oculus will be able to release a more stable software/set of drivers/firmware eventually where you don't need to carry out these kind of things to make their products work correctly.
  • leo1954auleo1954au Posts: 325
    Nexus 6
    Had that happen both my senors and I just unplugged them then plugged them back and they were detected strait away
  • vannagirlvannagirl Posts: 1,328 Poster of the Week
    leo1954au said:
    Had that happen both my senors and I just unplugged them then plugged them back and they were detected strait away
    Yes i was also going to say this, had a little usb drop out but that fixed it.

    Thank you for info though for if it ever becomes more of an issue
    Look, man. I only need to know one thing: where they are. 
  • WebMaximusWebMaximus Posts: 43
    Lawnmower Man (or Woman)
    Physically unplugging a sensor and then plugging it back of course is an option but when you have the sensor plugged in at the backside of your computer I personally find it far more easy to simply restart a service.

    Then regardless what method you prefer I guess most would agree you shouldn't need to use any of these methods.

    I have no other hardware requiring to be unplugged every now and then like this and I would like to think this is not how the developers at Oculus intended it to work.
  • whoa182whoa182 Posts: 380
    Trinity
    I've had this issue on and off since the last update. Unplugging and plugging them back in seems to work.
    CPU: i5-4690K 4.50 GHZ RAM: 8.00 GB Corsair Vengence GFX: Nvidia GTX 970 HDD: 2TB MONITOR: Samsung U28D590 27" 4K Res
  • leo1954auleo1954au Posts: 325
    Nexus 6
    Yes mine only started since the last update too
Sign In or Register to comment.