New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Oculus rift issue "too many lost IMU samples"

WikifulWikiful Posts: 5
Virtual Boy (or Girl)
Hello everyone,
I have been playing with my Oculus for two week and recently I got some issues.
Every 5 minutes, my screen on the Oculus freeze for 3-5 seconds and it's written on the settings of the oculus home : "too many lost IMU samples.".

I used an extension cord on my HDMI port, on the USB of the Oculus screen and on one of my sensor, but I have tested without it and it didn't change anything.
I also have bought this controller card ( https://www.amazon.fr/gp/product/B01KTGPOSC/ref=oh_aui_detailpage_o01_s01?ie=UTF8&psc=1 ) to add additional USB 3.0 port but Oculus home don't detect it as a 3.0 USB port. (Does it come from the card, my motherboard ? Could it cause the problem ?)


I tried to play with that but it's getting really uncomfortable, that why I hope the community could help me in some way.
Thanks for your answers and sorry for my English, it's not my native language.
I leave you with this gif that show the error from Oculus home and my spec : https://i.gyazo.com/8d5075385734ab5a6f4176f91426b490.gif

Intel Core i7 3770 3.40 GHz
ASUSTeK COMPUTER INC. P8B75-M Rev X.0x
NVIDIA GeForce GTX 970
16 Go RAM DDR3 666.54 MHz

Answers

  • WikifulWikiful Posts: 5
    Virtual Boy (or Girl)
    I also hear that the AI suite could cause this kind of issue but uninstalled it didn't fix anything.

  • SiilkSiilk Posts: 49
    Lawnmower Man (or Woman)
    Had the same issue with one of my sensors. After some experimenting, managed to get rid of it by switching sensor into a different USB port; had absolutely no HMD or sensor issues since then. Funnily enough, USB port I initially used was giving my wireless mouse "hiccups" and made cursor stutter quite often when I plugged it's dongle into that port so I suspect some sort of USB data packet loss was causing the issue.

    Note, all ports are built-in mother board USBs so, all in all, I have a feeling that with all sensors, HMD and other devices plugged in, MB USB controllers were having troubles serving all the ports at the same time.

    Another thing I heard of which may cause this is the fact that some USB controllers, including built in stuff, might have trouble properly powering all the USB ports when a lot of power-hungry devices are plugged in. Some people recommend trying a powered USB 3.0 hub to rule out the power issue but I haven't tried this option myself.

    Alternatively it might be a faulty USB port, at least in my case anyway. I'll try to diagnose it at some point in the future but for now I just avoid using the port in question.
  • SiilkSiilk Posts: 49
    Lawnmower Man (or Woman)
    edited September 12
    Oh, about USB 2.0 ports: while I was still experimenting with my gaming laptop before building a desktop PC for oculus, I used USB 2.0 for most of the oculus hardware(laptop only had 1 actual USB 3.0 port, the rest being 2.0s) and even when everything was plugging into 2.0s I had no packet loss whatsoever.

    Edit:
    Regarding PCI USB cards, I heard that only one specific card is verified to work with well oculus, namely 4 port Inateck PCI-E USB 3.0(I believe this is the one: https://www.amazon.com/Inateck-Carte-PCI-rouge-USB3-0/dp/B00B6ZCNGM/). Haven't tested myself so cannot confirm/deny this but a lot of people on the internet were mentioning that you should specifically buy this one. Then again, I read some people having troubles with USB ports even after buying that card so it's hardly a magic bullet...

  • WikifulWikiful Posts: 5
    Virtual Boy (or Girl)
    Thank you so much for your answer.

    I will tried to connect my oculus and all the sensors on that controller card and see if it fix my problem.
    (Anyway, I don't know if I well understood your messages and if it will be enough or if I need to unplug some of my components - like my mouse, my keyboard and my microphone - to free some power to my USB controller)
  • WikifulWikiful Posts: 5
    Virtual Boy (or Girl)
    Well, I have tried everything. I have put my oculus on every USB port and it didn't change anything. I also tried to unplung my sensors to see if the problem come from them but my headset still bug, and it's the same if I unplung every components on the USB port.

    I don't know what cause my problem and I don't think that the new controller card will fix anything )=
  • SiilkSiilk Posts: 49
    Lawnmower Man (or Woman)
    Do you have two sensors or just one? If you own two, you can try unplugging the sensor which reports errors to see how your system will behave with just one sensor. Additionally, try updating your USB controller and motherboard chipset drivers.

    Another thing you can do is try the oculus on another PC if you have a way to do so, ask a friend or a co-worker if you only have one PC at home. It doesn't have to be a powerful PC as you only need to confirm if your sensor will report any errors when plugged into a different PC.

    And at this point, I recommend opening a support ticket as it might be a faulty sensor.


  • WikifulWikiful Posts: 5
    Virtual Boy (or Girl)
    Hi,
    to answer quickly to your questions :
    -I have two sensors
    -I already tried to see what happen when I disconnect them
    -The issue come from the headset and not from the sensor
    -All my drivers are up to date
    -I opened a support ticket two days ago and we are working on my problem.

    But thanks for your answer. It's a good idea to test my Oculus on an other computer, I will tried on my laptop (even if he only have two USB 3 port. Maybe I will put the headset on a USB 2 port or maybe I will only plug one sensor).
    Anyway, the support is helping me now, thank you for your answers - you was the only one )=.
  • SiilkSiilk Posts: 49
    Lawnmower Man (or Woman)
    edited September 16
    From my experience testing oculus on my laptop, you can plug everything including the headset into USB 2.0 and it will still pass the hardware setup. You will not get the top performance that way but as long as you only need to confirm if you would have packet loss issues you should be fine.

    Another thing to check: if your packet loss issue is reported by HMD itself, try checking the headset cable, especially the connector which plugs into the headset. I encountered a good amount of posts about connector being faulty or straight up DoA due to bend pins. Accessing connector is a bit tricky as you have to remove the facial interface(aka the soft face-hugging part) of your headset first. Facial interface is removable but as you're already in contact with oculus support make sure to confirm that this will not void your warranty(it wouldn't but it's better to hear it from a customer service rep rather than a random internet person).

    Anyway, examine *both* ends of HMD cable, look for bent, out of place or missing pins. Also examine the cable itself. Start the oculus home(you might need to put something on top of the presence sensor inside the headset to trick it into thinking you're wearing it) and try to methodically bend small sections of the cable lightly, one by one, to see if there are any segments which might be damaged. After that, wiggle the connector on the headset lightly to check if the port is loose.

Sign In or Register to comment.