New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

CV1: No sound in rift headphones

KNP54KNP54 Posts: 148
Art3mis
I have no sound output in the rift headphone either in home, or in VR games when I set the output device to Rift Headphones or Audio Mirroring.
Before I was using my own headphones with the rift and that was working fine but I decided I was going to try the rift headphone for the sake of convenience.
I know it's a software issues since I CAN make them them work sometimes by restarting the OVR service and home several times. And also if I set my windows default audio output to the rift headphones and play music for example, the rift headphones works. So, it's definitely not a hardware issue.
Tagged:

Comments

  • KNP54KNP54 Posts: 148
    Art3mis
    Here are the logs.... This one looks suspicious:

    [Service_2017-10-11_16.27.15.txt] 11/10 22:49:50.289 {!ERROR!} [OAF ERROR] ..\..\..\audio\mirroring\Mirror.cpp(307) : Windows encountered an error: Unknown error 0x88890009 (1971052)
    [Service_2017-10-11_16.27.15.txt] 11/10 22:49:50.289 {!ERROR!} [AudioMirroringController] Windows encountered an error: Unknown error 0x88890009

  • cyberealitycybereality Posts: 22,779 Oculus Staff
    I see this error, which is pretty serious (actually, not sure how anything works without that).
    "Windows 10 system doesn't appear to have RiftDisplay.inf installed. Cannot use DXGI 2 path successfully."
    To fix you need to go to this folder:
    C:/Program Files/Oculus Runtime VR Drivers/Drivers/Monitor
    And right click RiftDisplay.inf and choose Install.

    In terms of the audio problem, it may be a conflicting program. There are known conflicts with Asus Sonic/AI Suite, VoiceMeeter, M-Audio, and other sound background applications. If you have something like that on the PC it may be a good idea to uninstall and see if that helps.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • KNP54KNP54 Posts: 148
    Art3mis
    I installed RiftDisplay.inf and it's not showing the error anymore.
    As for audio, the only thing that is remotely audio related installed is OpenAL. It might have come with a game I installed? I don't remember installing OpenAL. Should I uninstall it?
    I had Asus AI Suite installed before but I uninstalled it a long time ago.

    I also have more details on the audio symptoms:
    Audio in the rift only works the first time OVR service is launched. If I close home, and relaunch home, audio stops working in the rift. Audio mirrors correctly to speakers all the time though.
  • cyberealitycybereality Posts: 22,779 Oculus Staff
    Maybe try updating audio drivers for your sound card / motherboard. 
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • KNP54KNP54 Posts: 148
    Art3mis
    edited October 13
    Ok, so I backed up all my game and I tried Beta/Restart Oculus... did not fix audio issues
    I then completely reinstalled oculus software.. and still the same audio issue...

    But now new problem: I restored my games and every game I try to reinstall says "Sorry, we couldn't install <game name>. Visit Oculus Support to get help."

    Edit : nevermind the last part, I forgot to copy the manifest folder...
  • KNP54KNP54 Posts: 148
    Art3mis
    Fixed it!!!

    Right-click speak icon in system tray,
    Select Playback Devices,
    Select Headphones (Rift Audio),
    Properties,
    Advanced,
    Default Format = 2 channel, 16 bit, 44100 Hz (CD Quality).


    If this is set to 2 channel, 16 bit, 48000 Hz (DVD Quality) I have the audio bug!!
Sign In or Register to comment.