New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Installer fails OVRlibrarian.exe 104

everything unplugged

AV disabled

firewall off

842mb downloaded (about 15 times!)

get this error. please help

[Debug] [29/03/2016 04:31:06] Decoded hash 344f9fcd009a35395321936e353ec8f92e395d06a278dd93da91eef0d699e404.
[Debug] [29/03/2016 04:31:06] Installing 'Visual C++ 2013' redistributable.
[Debug] [29/03/2016 04:31:06] Installing 'Visual C++ 2013 x86' redistributable.
[Debug] [29/03/2016 04:31:06] Installing 'Visual C++ 2015' redistributable.
[Debug] [29/03/2016 04:31:07] Install 'Install necessary redistributables.' succeeded.
[Debug] [29/03/2016 04:31:07] Install 'Set up C:\Program Files (x86)\Oculus and OVRLibrarian.' succeeded.
[Debug] [29/03/2016 04:31:07] Installing oculus-runtime.
[Error] [29/03/2016 04:31:07] Process C:\Program Files (x86)\Oculus\Support\oculus-librarian\OVRLibrarian.exe exited with code 104.
[Debug] [29/03/2016 04:31:07] Install 'Install all downloaded packages.' failed.
[Warning] [29/03/2016 04:31:07] Rolling back installation.
[Debug] [29/03/2016 04:31:07] Uninstall 'Install all downloaded packages.' succeeded.
[Debug] [29/03/2016 04:31:07] Uninstall 'Set up C:\Program Files (x86)\Oculus and OVRLibrarian.' succeeded.
[Debug] [29/03/2016 04:31:07] Uninstall 'Install necessary redistributables.' succeeded.
[Debug] [29/03/2016 04:33:10] Removing temp directory.
[Warning] [29/03/2016 04:33:10] Couldn't remove temp directory.
[Debug] [29/03/2016 04:33:10] Exiting with code 1.


Cant attach file as there is no attachment option

cant paste all file as its too big

«1

Comments

  • cyberealitycybereality Posts: 22,757 Oculus Staff
    Yeah, you can attach files on the forum. Did you try this?


    I'll ask about your error.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • Nope, because I don't normally look at the formatting bar for attachments!

    Here it is.

  • cyberealitycybereality Posts: 22,757 Oculus Staff
    edited March 2016
    No problem. I'll check tomorrow.
    You can also just drag and drop files from Windows Explorer into the post box.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • I tried drag and drop, it closed the window whenever the browser lost focus.
  • Same issue here. I am a sad panda :(
  • JoaquinGJoaquinG Posts: 2
    Same problem here
    [Debug] [30/03/2016 12:07:11] Installing 'Visual C++ 2015' redistributable.
    [Debug] [30/03/2016 12:07:33] Process C:\Users\jgracia\AppData\Local\Temp\OculusSetup-dae3de16-d3d0-4ac1-9417-668d3af11286\visual-cpp-2015.exe exited with code 0 (success).
    [Debug] [30/03/2016 12:07:33] Install 'Install necessary redistributables.' succeeded.
    [Debug] [30/03/2016 12:07:38] Install 'Set up C:\Program Files (x86)\Oculus and OVRLibrarian.' succeeded.
    [Debug] [30/03/2016 12:07:38] Installing oculus-runtime.
    [Debug] [30/03/2016 12:07:38] Process C:\Program Files (x86)\Oculus\Support\oculus-librarian\OVRLibrarian.exe exited with code 104 (failure).
    [Debug] [30/03/2016 12:07:38] Install 'Install all downloaded packages.' failed.
    [Warning] [30/03/2016 12:07:38] Rolling back installation.
    [Debug] [30/03/2016 12:07:38] Uninstall 'Install all downloaded packages.' succeeded.
    [Debug] [30/03/2016 12:07:38] Total files inside Oculus directory: 4 files
    [Debug] [30/03/2016 12:07:38] Initial RmGetResut: 234, number: 1, reason 0
    [Debug] [30/03/2016 12:07:38] Second RmGetResut: 0, number: 1, reason 0
    [Debug] [30/03/2016 12:07:38] Shutting down resources
    [Error] [30/03/2016 12:07:38] Restart Manager cannot shut down resources
    [Debug] [30/03/2016 12:07:38] Restarting downed resources
    [Debug] [30/03/2016 12:07:38] Uninstall 'Set up C:\Program Files (x86)\Oculus and OVRLibrarian.' failed.
    [Debug] [30/03/2016 12:07:38] Uninstall 'Install necessary redistributables.' succeeded.

  • lamour42lamour42 Posts: 118
    Art3mis
    Same error for my PC at work (behind firewall), without any oculus device attached. No problem installing at home with my DK2.
  • SimonCSimonC Posts: 1

    Same issue. Am discussing our group policy settings tomorrow with the IT dept.

    FWIW Looking at the windows event logs I find this:

    The OVRLibraryService service was unable to log on as NT SERVICE\OVRLibraryService with the currently configured password due to the following error: Logon failure: the user has not been granted the requested logon type at this computer. Service: OVRLibraryService Domain and account: NT SERVICE\OVRLibraryService This service account does not have the required user right "Log on as a service."

  • cyberealitycybereality Posts: 22,757 Oculus Staff
    I'll ping the engineering team about this. Sounds like a permission issue.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • SimonC has hit the nail on the head. I just did a repeat install and looked at the  system log and sure enough NT Service\OVRLibraryService failed its logon. And I know why

    THIS IS A DOMAIN PC, YOU CANT ADD USERS TO THE DOMAIN, STOP TRYING TO DO THAT, USE THE LOCAL SYSTEM SERVICE ACCOUNT INSTEAD!

    My guess is that anyone who is part of a domain will have this error!

  • PopopinselPopopinsel Posts: 179
    Art3mis
    It's more likely you guys have a Group Policy assigned that's permitting user accounts to logon as a service.

    You can check it like this:

    Open secpol.msc (either via Start Menu search or WIN + R) and go to "Security Settings -> Local Policies -> User Rights Assignments" and look for the policies named "Deny logon as a service" (should be an empty list) and "Logon as a Service" (should contain "NT SERVICE\OVRLibraryService" or "NT SERVICE\ALL SERVICES").

    But please be reminded that your IT dept has these settings likely for security reasons so be careful. Best is indeed to check with them.
  • This wont work on a domain system where changes have to be made though the group policy. This is why they should not be trying to create users with system privileges in the first place.
  • ronaldkitchingronaldkitching Posts: 2
    NerveGear
    I upgraded my windows 7 to windows 10 I tried to install oculus system i am expecting my oculus rift in june ,my computer comes up with this error ,OVRLibrarian.exe application error , the application was unable to start correctly (0xc000007b) click ok to close application , any help or information on what could be the problem i also am unable to install a windows update at the moment ?
  • radix88radix88 Posts: 10
    edited April 2016
    I have the same error, "\OVRLibrarian.exe exited with code 104 (failure)." I followed Popopinsel's instructions and found that I was not allowed to make changes to "Logon as a Service" and it did not contain "NT SERVICE\OVRLibraryService" or "NT SERVICE\ALL SERVICES"

    Are there any other possible workarounds?
  • hmexxhmexx Posts: 5
    Can we PLEASE get a fix for this? Waiting for my VR for 2 years and now that it's here I'm stuck because of a software installation error. I also don't have an AV. It's my home PC so I have full control over its entire setup/settings, but I need instructions on how to fix this. PLEASE!!!!
  • ShaneCShaneC Posts: 10
    Same here, I posted a topic and submitted a support ticket, no response yet, its been days....
  • AlricAlric Posts: 112
    Hiro Protagonist
    I've got exactly the same issue! Please cyber can we have an update on this. I was one of the first to pre-order but how silly when the software won't even install. Tried every work around but nothing will work.....
  • cyberealitycybereality Posts: 22,757 Oculus Staff
    We have a fix for this in the installer (coming soon), but for now the workaround is manually granting NT SERVICE\ALL SERVICES the right to log on as as service. See this guide for details:
    http://myvirtualbytes.com/home/logon-as-a-service-user-right-to-nt-serviceall-services-for-vcenter-6/
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • hmexxhmexx Posts: 5
    @cybereality ;. Just an FYI, that workaround does not fix the issue on my PC... so expect it to not solve the issue for everyone when your next installer is out. If you need me to do any other testing/logging on my PC to help you, happy to help. I'm a software developer. That NT SERVICE\ALL SERVICES is already in my list of "right to log on"

    H.
  • AlricAlric Posts: 112
    Hiro Protagonist
    Also wanted to make cybereality aware that this work around doesn't work for me either so if that's all that's different in the updated version it still won't work for me. I also have NT SERVICE/ALL SERVICES in my list of right to log on. Something else is causing the issue.
  • Blue_AngelBlue_Angel Posts: 23
    Brain Burst
    I do not have the "Group Policy Management Editor" snap in, how come? Im in almost over my head here ;)
  • hmexxhmexx Posts: 5
    Come on Oculus support. Do you realize how frustrating it is to receive a piece of hardware and have to watch it sit on the shelf for 11 days (and counting) because the installer won't work? 

    We need an answer.... like now. Are you looking into this? Do you have any idea what it could be? Can we help you get to the bottom of it? I'm happy to talk with someone over the phone and debug on my side. I'm quite technical (developer). Please!!!
  • AlricAlric Posts: 112
    Hiro Protagonist
    Totally agree with 'hmexx'. I am in the same boat, I have had the new rift for nearly a week now and all I can do is look at it because the Oculus software fails to install due to OVRlibrarian.exe 104 error.

    In 20 years of computing I've never had this much frustration with software not installing. There is usually always a fix or work around but after days and days of trying it seems our only hope is for Oculus to fix their software. Please, please can we get an update on this. I'm trying to be patient but I have £500 worth of unusable hardware which isn't my fault.
  • UrbanLogicGamesUrbanLogicGames Posts: 15
    NerveGear
    edited April 2016
    I'm having the same error unfortunately... Pretty much a clean install of Windows 10, anti-virus disabled, up to date graphics drivers etc. I've attached logs in case they're of any use.

    EDIT: Scratch that, I didn't realise there was a newer version (I must have downloaded the installer just a few hours before the update). The latest version installed correctly, so those having the 104 error might want to try the latest installer. :smile: 
  • Tried the latest one, no difference. I was able to install on a clean W10Home machine. But that doesn't help install it on my main dev pc.
  • AlricAlric Posts: 112
    Hiro Protagonist
    Oh so Oculus have updated the software without telling anyone? Annoying, but I will go give a try and report back.....fingers crossed.
  • AlricAlric Posts: 112
    Hiro Protagonist
    Didn't have high hopes at it was still the same file name and the same 844mb file size BUT............

    IT NOW INSTALLS :)

    It hesitated where it would normally fail and waheyyy it installed successfully so something must have changed. Following the rest of the setup now.....
  • JoaquinGJoaquinG Posts: 2
    Still same error.

    "The OVRLibraryService service was unable to log on as NT SERVICE\OVRLibraryService with the currently configured password due to the following error:
    Logon failure: the user has not been granted the requested logon type at this computer.
     
    Service: OVRLibraryService
    Domain and account: NT SERVICE\OVRLibraryService
     
    This service account does not have the required user right "Log on as a service."
     
    User Action
     
    Assign "Log on as a service" to the service account on this computer. You can use Local Security Settings (Secpol.msc) to do this. If this computer is a node in a cluster, check that this user right is assigned to the Cluster service account on all nodes in the cluster.
     
    If you have already assigned this user right to the service account, and the user right appears to be removed, check with your domain administrator to find out if a Group Policy object associated with this node might be removing the right."

  • asteedasteed Posts: 3
    This is still a problem - another week has passed! I am trying to install on a managed PC in a student lab, so not an option to change the group policy.
  • cyberealitycybereality Posts: 22,757 Oculus Staff
    Try running this on a command line first (and delete it once you're done).
    sc create "OVRLibraryService" binPath= c:\temp\someprogram.exe DisplayName= "OVRLibraryService FAKE" type= own
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
«1
Sign In or Register to comment.