New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

OVRLibrarian.exe exited with code 104 (failure)

ShaneCShaneC Posts: 10
I can't install the new Oculus software to go with my release Rift that just arrived. I get the "Sorry we encountered an error during installation."

Having to download this entire 800 meg file ever time is not good. Not being able to set the install directory also not good.

I read some of the other threads with install issues.  I use Norton 360, which manages the windows firewall. I tried disabling it, but i still get this error.  

Any fixes for this yet? 

Here is what the log says... what does code 104 mean?

[Debug] [3/31/2016 12:27:21 AM] Installing 'Visual C++ 2013' redistributable.
[Debug] [3/31/2016 12:27:30 AM] Process C:\Users\Shane\AppData\Local\Temp\OculusSetup-13209861-a091-40e5-a9ad-d35dc42b6c2e\visual-cpp-2013.exe exited with code 0 (success).
[Debug] [3/31/2016 12:27:30 AM] Installing 'Visual C++ 2013 x86' redistributable.
[Debug] [3/31/2016 12:27:52 AM] Process C:\Users\Shane\AppData\Local\Temp\OculusSetup-13209861-a091-40e5-a9ad-d35dc42b6c2e\visual-cpp-2013-x86.exe exited with code 0 (success).
[Debug] [3/31/2016 12:27:52 AM] Installing 'Visual C++ 2015' redistributable.
[Debug] [3/31/2016 12:28:13 AM] Process C:\Users\Shane\AppData\Local\Temp\OculusSetup-13209861-a091-40e5-a9ad-d35dc42b6c2e\visual-cpp-2015.exe exited with code 0 (success).
[Debug] [3/31/2016 12:28:13 AM] Install 'Install necessary redistributables.' succeeded.
[Debug] [3/31/2016 12:28:13 AM] Total files inside Oculus directory: 0 files
[Debug] [3/31/2016 12:28:13 AM] Initial RmGetResut: 0, number: 0, reason 0
[Debug] [3/31/2016 12:28:13 AM] Install 'Set up C:\Program Files (x86)\Oculus and OVRLibrarian.' succeeded.
[Debug] [3/31/2016 12:28:13 AM] Installing oculus-runtime.
[Debug] [3/31/2016 12:28:14 AM] Process C:\Program Files (x86)\Oculus\Support\oculus-librarian\OVRLibrarian.exe exited with code 104 (failure).
[Debug] [3/31/2016 12:28:14 AM] Install 'Install all downloaded packages.' failed.
[Warning] [3/31/2016 12:28:14 AM] Rolling back installation.
[Debug] [3/31/2016 12:28:14 AM] Uninstall 'Install all downloaded packages.' succeeded.
[Debug] [3/31/2016 12:28:14 AM] Total files inside Oculus directory: 4 files
[Debug] [3/31/2016 12:28:14 AM] Initial RmGetResut: 0, number: 0, reason 0
[Debug] [3/31/2016 12:28:14 AM] Uninstall 'Set up C:\Program Files (x86)\Oculus and OVRLibrarian.' succeeded.
[Debug] [3/31/2016 12:28:14 AM] Uninstall 'Install necessary redistributables.' succeeded.

Thanks!

Comments

  • PopopinselPopopinsel Posts: 179
    Art3mis
    Does this or this help?
  • ShaneCShaneC Posts: 10
    My Nvidia drivers are up to date.  This is a home PC, and I have never had issues like this installing apps before.

    I do not see the Windows Firewall service listed under services. Is it actually listed as that?

    If I run Windows Firewall I get this.


    If you right click on the Norton 360 icon, you get this menu. I tried disabling Smart Firewall, and Auto-Protect.



    I also set the firewall to allow OculusSetup.exe.



    I tried installing again after this, and still get the same error.

    [Debug] [3/31/2016 8:44:06 AM] Installing 'Visual C++ 2013' redistributable.
    [Debug] [3/31/2016 8:44:16 AM] Process C:\Users\Shane\AppData\Local\Temp\OculusSetup-466bf2d9-3f1c-4ae9-9908-1fa55d874d2c\visual-cpp-2013.exe exited with code 0 (success).
    [Debug] [3/31/2016 8:44:16 AM] Installing 'Visual C++ 2013 x86' redistributable.
    [Debug] [3/31/2016 8:44:37 AM] Process C:\Users\Shane\AppData\Local\Temp\OculusSetup-466bf2d9-3f1c-4ae9-9908-1fa55d874d2c\visual-cpp-2013-x86.exe exited with code 0 (success).
    [Debug] [3/31/2016 8:44:37 AM] Installing 'Visual C++ 2015' redistributable.
    [Debug] [3/31/2016 8:44:56 AM] Process C:\Users\Shane\AppData\Local\Temp\OculusSetup-466bf2d9-3f1c-4ae9-9908-1fa55d874d2c\visual-cpp-2015.exe exited with code 0 (success).
    [Debug] [3/31/2016 8:44:56 AM] Install 'Install necessary redistributables.' succeeded.
    [Debug] [3/31/2016 8:44:57 AM] Install 'Set up C:\Program Files (x86)\Oculus and OVRLibrarian.' succeeded.
    [Debug] [3/31/2016 8:44:57 AM] Installing oculus-runtime.
    [Debug] [3/31/2016 8:44:57 AM] Process C:\Program Files (x86)\Oculus\Support\oculus-librarian\OVRLibrarian.exe exited with code 104 (failure).
    [Debug] [3/31/2016 8:44:57 AM] Install 'Install all downloaded packages.' failed.
    [Warning] [3/31/2016 8:44:57 AM] Rolling back installation.
    [Debug] [3/31/2016 8:44:57 AM] Uninstall 'Install all downloaded packages.' succeeded.
    [Debug] [3/31/2016 8:44:57 AM] Total files inside Oculus directory: 4 files
    [Debug] [3/31/2016 8:44:57 AM] Initial RmGetResut: 0, number: 0, reason 0
    [Debug] [3/31/2016 8:44:58 AM] Uninstall 'Set up C:\Program Files (x86)\Oculus and OVRLibrarian.' succeeded.
    [Debug] [3/31/2016 8:44:58 AM] Uninstall 'Install necessary redistributables.' succeeded.

    I also looked at the Norton 360 history after this install failed, and nothing new shows up.

    I also did right click run as Administrator.

    Still same error.








  • ShaneCShaneC Posts: 10
    Bump
  • ShaneCShaneC Posts: 10
    Bump Bump!!
  • hmexxhmexx Posts: 5
    Seems you have the same problem as myself. I've probably downloaded the 800mb 40 times now. Not the most useful use of internet bandwidth! Hopefully we hear something today.
  • hmexxhmexx Posts: 5
    Shane, let's see if we can get closer to the problem ourselves. Can you open "Event Viewer", Select "Windows Logs" -> "System", and look through the entries and see an ERROR during installation times that says:

    A timeout was reached (30000 milliseconds) while waiting for the OVRLibraryService service to connect.

    Thanks

  • sidorasidora Posts: 6
    NerveGear
    on my side i am getting :OVRLibrarian.exe exited with code 12(failure)
  • ShaneCShaneC Posts: 10
    My Windows event log says... A timeout was reached (30000 milliseconds) while waiting for the OVRLibraryService service to connect.
  • mfimichaelmfimichael Posts: 3
    NerveGear
    I just got a brand new Dell XPS in today (the one that is supposedly Oculus ready) and it fails to install the runtime as well. At first, it seems it was because I had the VC++ 2015 redistributables already installed, so I had to remove them. Now I am getting this error as well.

    Process C:\Program Files (x86)\Oculus\Support\oculus-librarian\OVRLibrarian.exe exited with code 7 (failure).

    Only thing I see in the event viewer is Event 7024, Service Control Manager
    The OVRLibraryService service terminated with the following service-specific error: 
    The storage control blocks were destroyed.

  • sidorasidora Posts: 6
    NerveGear
    I uninstalled all c++ redistributables, rebooted. and then it worked for me.
  • mfimichaelmfimichael Posts: 3
    NerveGear
    I've tried uninstalling all the redistributables, but I still seem to be hung on the OVRLibrarian.exe error. :/
  • vacakvacak Posts: 1
    any update on this? I have the same problem on an asus oculus ready pc and a oculus cv1.. cannot do anything. I download that 800 mb stuff like 20 times so far.
  • Got past the OVRLibraryService after uninstalling McAfee and rebooting. Have the ASUS Oculus Ready G20CB-WS71 bundle.
  • BitRiftBitRift Posts: 3
    Bump... "Process C:\Program Files\Oculus\Support\oculus-librarian\OVRLibrarian.exe exited with code 104 (failure)."

    Cannot install runtime at all, have tried much googling and followed all suggestions. So frustrating that you need to download the data each time it fails.
  • BitRiftBitRift Posts: 3
    edited May 2016
    BitRift said:
    Bump... "Process C:\Program Files\Oculus\Support\oculus-librarian\OVRLibrarian.exe exited with code 104 (failure)."

    Cannot install runtime at all, have tried much googling and followed all suggestions. So frustrating that you need to download the data each time it fails.
    This was caused by a problem running the OVRLibraryService on my work domain. There was an error in my Windows Event Viewer about not having required user right "Log on as a service". Disconnected from the domain and it's fine.

    Have downloaded the installer data about 20 times now, really time-consuming, please provide a redist installer that doesn't download anything.
  • cyberealitycybereality Posts: 22,757 Oculus Staff
    edited June 2016
    Try running this on a command line first (and delete it once you're done).
    sc create "OVRLibraryService" binPath= c:\temp\someprogram.exe DisplayName= "OVRLibraryService FAKE" type= own
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • sh0v0rsh0v0r Posts: 498
    Hiro Protagonist
    I'm having the same issue on my work machine. Full admin rights, no virus scanner, uninstalled c++ runtimes, cleaned out every possible Oculus trace except cached install files, tried 8 times to install.

    Here's the log, last entry seems to be consistently issues with deleting files from the temp folder:
     
    Starting up OculusSetup v1.5.0.237814.
    [Debug] [27/06/2016 3:20:45 PM] Setup action:  Install.
    [Debug] [27/06/2016 3:20:45 PM] Created secure temp directory at 'C:\Users\sedwards\AppData\Local\Temp\OculusSetup-3377b8f4-5053-4e69-9b27-f67bb487c897'.
    [Debug] [27/06/2016 3:20:45 PM] Extracting asset 'OculusSans-Regular.otf'.
    [Debug] [27/06/2016 3:20:45 PM] Extracting asset 'OculusSans-SemiBold.otf'.
    [Debug] [27/06/2016 3:20:45 PM] Extracting asset 'ManagedOpenSsl.dll'.
    [Debug] [27/06/2016 3:20:45 PM] Extracting asset 'libeay32.dll'.
    [Debug] [27/06/2016 3:20:45 PM] Extracting asset 'ssleay32.dll'.
    [Debug] [27/06/2016 3:20:45 PM] Extracting asset 'Intrinsics.dll'.
    [Debug] [27/06/2016 3:20:45 PM] Extracting asset 'Microsoft.Deployment.Compression.dll'.
    [Debug] [27/06/2016 3:20:45 PM] Extracting asset 'Microsoft.Deployment.Compression.Cab.dll'.
    [Debug] [27/06/2016 3:20:45 PM] Initialising Analytics.
    [Debug] [27/06/2016 3:20:45 PM] Initialising MachineAnalytics.
    [Debug] [27/06/2016 3:20:45 PM] Anti-virus found: Windows Defender(397568, Enabled, Up-to-date)
    [Debug] [27/06/2016 3:20:46 PM] Starting preflight checks.
    [Debug] [27/06/2016 3:20:47 PM] Found candidate install locations:  [C:\Program Files\Oculus, D:\Oculus]
    [Debug] [27/06/2016 3:20:47 PM] Finished network-blocked initialisation.
    [Debug] [27/06/2016 3:20:47 PM] RunCheck 'Must be able to reach Oculus servers for OculusSetup configuration.' succeeded.
    [Debug] [27/06/2016 3:20:47 PM] RunCheck 'OculusSetup must be compatible with the current Oculus Gestalt.' succeeded.
    [Debug] [27/06/2016 3:20:47 PM] RunCheck 'CPU must support SSE 4.2 (be at least Nehalem architecture).' succeeded.
    [Debug] [27/06/2016 3:20:47 PM] RunCheck 'Must be running 64-bit Windows 7 SP1 / 8.1 or newer.' succeeded.
    [Debug] [27/06/2016 3:20:47 PM] RunCheck 'If on Windows 7, must have hotfixes KB2670838 and KB3033929 installed.' succeeded.
    [Debug] [27/06/2016 3:20:47 PM] RunCheck 'Must have an eligible drive for installation.' succeeded.
    [Debug] [27/06/2016 3:20:47 PM] RunCheck 'Must not have the standalone Runtime installed.  If this fails, please uninstall 'Oculus Runtime' and reboot, then try again.' succeeded.
    [Debug] [27/06/2016 3:20:47 PM] RunCheck 'Must not have a reboot pending.' succeeded.
    [Debug] [27/06/2016 3:20:47 PM] All preflight checks passed.
    [Debug] [27/06/2016 3:21:14 PM] Install location:  'C:\Program Files\Oculus\'.
    [Warning] [27/06/2016 3:21:14 PM] Found previous download directory
    [Debug] [27/06/2016 3:21:14 PM] Created secure temp directory at 'C:\OculusSetup-DownloadCache'.
    [Debug] [27/06/2016 3:21:48 PM] Reusing previously downloaded 'oculus-dreamdeck-nux'
    [Debug] [27/06/2016 3:21:48 PM] Installing 'Visual C++ 2013' redistributable.
    [Debug] [27/06/2016 3:21:49 PM] Process C:\OculusSetup-DownloadCache\visual-cpp-2013.exe exited with code 0 (success).
    [Debug] [27/06/2016 3:21:49 PM] Installing 'Visual C++ 2013 x86' redistributable.
    [Debug] [27/06/2016 3:21:50 PM] Process C:\OculusSetup-DownloadCache\visual-cpp-2013-x86.exe exited with code 0 (success).
    [Debug] [27/06/2016 3:21:50 PM] Installing 'Visual C++ 2015' redistributable.
    [Debug] [27/06/2016 3:21:51 PM] Process C:\OculusSetup-DownloadCache\visual-cpp-2015.exe exited with code 0 (success).
    [Debug] [27/06/2016 3:21:51 PM] Install 'Install necessary redistributables.' succeeded.
    [Debug] [27/06/2016 3:21:51 PM] Install 'Create Oculus Library service.' succeeded.
    [Debug] [27/06/2016 3:21:51 PM] Install 'Create secure install directory.' succeeded.
    [Debug] [27/06/2016 3:21:51 PM] Extracting asset 'Oculus.ico'.
    [Debug] [27/06/2016 3:21:51 PM] Install 'Deploy Library service binary.' succeeded.
    [Debug] [27/06/2016 3:21:51 PM] Install 'Create Oculus Registry keys.' succeeded.
    [Debug] [27/06/2016 3:21:51 PM] Install 'Set environment variables.' succeeded.
    [Debug] [27/06/2016 3:21:51 PM] Installing oculus-runtime.
    [Error] [27/06/2016 3:21:52 PM] Librarian exited code 104
    [Debug] [27/06/2016 3:21:52 PM] Install 'Install all downloaded packages.' failed.
    [Warning] [27/06/2016 3:21:52 PM] Rolling back installation.
    [Debug] [27/06/2016 3:21:52 PM] Uninstall 'Install all downloaded packages.' succeeded.
    [Debug] [27/06/2016 3:21:52 PM] Uninstall 'Set environment variables.' succeeded.
    [Debug] [27/06/2016 3:21:52 PM] Uninstall 'Create Oculus Registry keys.' succeeded.
    [Debug] [27/06/2016 3:21:52 PM] Uninstall 'Deploy Library service binary.' succeeded.
    [Debug] [27/06/2016 3:21:52 PM] Total files inside Oculus directory: 8 files
    [Debug] [27/06/2016 3:21:52 PM] Initial RmGetResut: 0, number: 0, reason 0
    [Debug] [27/06/2016 3:21:52 PM] Uninstall 'Create secure install directory.' succeeded.
    [Debug] [27/06/2016 3:21:52 PM] Uninstall 'Create Oculus Library service.' succeeded.
    [Debug] [27/06/2016 3:21:52 PM] Uninstall 'Install necessary redistributables.' succeeded.
    [Debug] [27/06/2016 3:21:56 PM] Removing working directory.
    [Warning] [27/06/2016 3:21:56 PM] Exception deleting 'C:\Users\sedwards\AppData\Local\Temp\OculusSetup-3377b8f4-5053-4e69-9b27-f67bb487c897':
    System.UnauthorizedAccessException: Access to the path 'Intrinsics.dll' is denied.
       at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive, Boolean throwOnTopLevelDirectoryNotFound)
       at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive, Boolean checkHost)
       at Dawn.Mixins.ReallyDeleteDirectory(String path)
    [Debug] [27/06/2016 3:21:56 PM] Scheduling delete of 'C:\Users\sedwards\AppData\Local\Temp\OculusSetup-3377b8f4-5053-4e69-9b27-f67bb487c897' on next reboot.
    [Debug] [27/06/2016 3:21:56 PM] Exiting with code 1.

  • denisdenis Posts: 5
    NerveGear
    Exactly the same also for me :(
    ...
    [Debug] [29/06/2016 00:04:00] Installing oculus-runtime.
    [Error] [29/06/2016 00:04:16] Librarian exited code 104
    [Debug] [29/06/2016 00:04:16] Install 'Install all downloaded packages.' failed.
    ...
  • lamour42lamour42 Posts: 118
    Art3mis
    a little different for me now:
    [Error] [29.06.2016 12:51:19] Librarian exited code 7
    [Error] [29.06.2016 12:51:19] Installation likely failed due to antivirus software

    Don't know if that reason is true. I have antivirus running all the time and very few software installations have problems with it. I run a managed PC here at office and cannot disable antivirus completely.

    This problem prevents the rift from being used inside our company (>70.000 people)!
  • denisdenis Posts: 5
    NerveGear
    Please can someone of oculus support explain what does code 104 mean? My oculus is still waiting in my box!
  • denisdenis Posts: 5
    NerveGear
    solved installing .net 4.6.1 . Please report framework 4.6.1 as a requirement
  • LBardosLBardos Posts: 5
    NerveGear
    woohoo! installing .net 4.6.1 worked for me too! thanks denis :)
  • budwheizzahbudwheizzah Posts: 153
    Hiro Protagonist
    I'm stunned this is still not fixed.
  • cfloutiercfloutier Posts: 14
    NerveGear
    edited August 2016
    ...
  • cfloutiercfloutier Posts: 14
    NerveGear
    Not better for me. I'm really fed up about this setup. I don't understand why it is not fixed so many time
  • He does not want to install the driver.
    Installing oculus-runtime.
    [Error] [11.09.2016 7:55:49] Librarian exited code 104
    [Debug] [11.09.2016 7:55:49] Install 'Dawn.Setup.InstallPackagesStep' failed.
  • cyberealitycybereality Posts: 22,757 Oculus Staff
    I think you have to install these Windows Updates KB2670838 and KB3033929
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
Sign In or Register to comment.