/ Forums
New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

New Forum for Store Submissions Questions

cyberealitycybereality Posts: 20,550 Oculus Staff
Hey, welcome to the new Store Submissions forum!
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 32GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
PowerColor RX 480 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

Comments

  • techstiltechstil Posts: 1
    Virtual Boy (or Girl)
    Hi, We have a very stable application called SceneThere that we've been running on 50 GearVR devices for 6 months now with no problems. Problem is that the Oculus Submission team does not get the application working at all. We've tried to release now for 1 month, but can't get through, and we also do not get any respons to our emails to the support email... We are completely clueless on how to proceed, because we have no way of reproducing the behaviour that they report... Our app has been running solid for a long time, so problem must be that our environment is different from the one that our app is being tested on.  Below is our email to submissions@oculus.com: 


    Dear Oculus, 

    Package name: com.scenethere
    File name: SceneThere-rc4.apk
    Version name: 1.0
    Version code: 4

    Regarding our application submission com.scenethere which was submitted on 19th of October: 

    We have now spent several man-days trying to replicate the error that was reported in your build test results on 21st october. (MEDIA_ERROR_SERVER_DIED), but we are unable to replicate the error that you report. For us to be able to move forward and publish this application in your store we need a closer collaboration and more details on your test environment. 

    We've been running our application successfully for 6 months on 50 different devices in several different countries, and also demoing it at UN's Habitat 3 conference for 4 hours for 4 days consecutive without anyone reporting any problems. (video of premier here)
    We are quite sure that our application is stable on our devices, and this is why we believe that the problem derives from a difference between your test environment and our phones, or possibly the process which you use for running the tests. 

    Can you please get back to us confirming the error with a real phone, and not an emulated environment? Please also confirm that your test system allows for playback of H.265 videos in 4K.


    Below are the error message that we received from you: 
  • cyberealitycybereality Posts: 20,550 Oculus Staff
    I'd recommend emailing submissions@oculus.com again. I was told we have people ready to respond. Thanks.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 32GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    PowerColor RX 480 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • DanoKablamoDanoKablamo Posts: 4
    Virtual Boy (or Girl)
    Hi!
    My game is made in Unity, I'm trying to get my game approved but I've failed the test where the Oculus Home window should open when I push the "Oculus Home" button.  But I don't have an Oculus remote, I only have an Xbox controller and I can't figure out how to get Unity to recognize the Xbox button or how to simulate the Oculus home button press.
    I've downloaded the Utilities and I have the OVRPlatformMenu.cs and OVRManager.cs on an empty gameobject with a DontDestroyOnLoad added. It should be working.
    Are there any specific tutorials or instructions on making this work?  Thank you! 
    It's the last and only thing I need to do to get my game into early access! Thanks.
    Dano
  • cyberealitycybereality Posts: 20,550 Oculus Staff
    I thought that was handled for you automatically. You can use an Xbox One controller (that comes with Rift) or even an Xbox 360 controller should be fine (I just tested it). You just press the Xbox button and it should bring up the Universal Menu.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 32GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    PowerColor RX 480 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • DanoKablamoDanoKablamo Posts: 4
    Virtual Boy (or Girl)
    edited November 2016
    You tested it on my game or some other game?
    It's not working on mine.

    It doesn't work in Lucky's Tale or any other experience for that matter!

    Edit: I just realized that OVRPlatformMenu.cs is for Mobile!  What is the equivalent on PC?
  • cyberealitycybereality Posts: 20,550 Oculus Staff
    I tested in on a sample Unity project. However, if it doesn't work in Lucky's Tale then it has nothing to do with your code and is likely something wrong on your system. 
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 32GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    PowerColor RX 480 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • DanoKablamoDanoKablamo Posts: 4
    Virtual Boy (or Girl)
    Ok awesome, and all you did was add OVRManager to an empty game object and you were good to go?
    I'll submit my latest build and see if it works for them haha.
  • vfergusonvferguson Posts: 64
    Hiro Protagonist
    Great idea! Happy to have a forum for these kinds of questions. :)
  • GlobalWheelzGlobalWheelz Posts: 1
    Virtual Boy (or Girl)
    I have been trying to upload png's and videos and builds for two days now. It often rejects the png screenshots for no apparent reason. They are correctly sized and png format. The video just idles at 0% and twice it has aborted after getting some percentile uploaded. I am going on my 6th try currently. The build I am uploading to the Store channel shuffles back and forth between 0% and 1% ..mostly staying at 0% for the past hour. It is only 69K MB..not exactly a huge game. Is your system working properly or am i banging my head against your system flaws?
  • cyberealitycybereality Posts: 20,550 Oculus Staff
    It may be network or firewall related. Can you try from a different network, or adjust firewall settings?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 32GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    PowerColor RX 480 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • coreyj7777coreyj7777 Posts: 3
    Virtual Boy (or Girl)
    Dear Oculus Developer support,
    Do you have any form of developer communication?
    Your pass/fail system gives ZERO information. Do you have live chat or a contact system that does something more than generate support ticket numbers that you never followed up on ?
    I have sent around 10 emails to you now, and have had one response. She could only say that she has no access to the fail report from your app testers. Pretty weird since she is developer support. Please help.
    Thanks
    Corey
  • coreyj7777coreyj7777 Posts: 3
    Virtual Boy (or Girl)
    Oculus Support,

    When I submit my app to the store for review, I'm getting a fail report for framerate not staying at 90fps. I'm not sure why report is happening. My app replicates exactly what is happening on the Oculus video player. During scene changes, the framerate drops, but immediately returns to 90fps. During video playback Voyeur VR stays at 90 fps and even maintains a higher performance headroom than Oculus's player. When testing my app with your debugger the app played at 90fps and I'm not seeing anything with fps drop. I've attached screen captures of your app's performance and a picture of my app's performance through the lens.

    So we are understandably confused. We have tested the app on multiple systems from the minimum system requirements to maximum. The FPS on Voyeur VR remains at a steady 90 FPS. So we need to see a screenshot from your evaluators with Voyeur VR playing a video at less than 90 FPS. We are not trying to insult you, its just that we have yet to see the error.

    Also do you have anyone that can call us? Or live chat? Do you have any form of communication with developers?

    Also we have tested the Entitlements check and it works on our end. So we need communication from you or a real tech report that delivers more info than just an elementary school form of pass/fail.

    I'm not certain what I need to do and would appreciate any help as to fixing the problem so that I can get my app published to your store.

    Thanks,

    -Corey




    From: Oculus Store <submissions@oculus.com>
    Sent: Monday, December 12, 2016 5:09 PM
    To: corey janssens
    Subject: [Oculus Support] Re: VoyeuR VR App Submission Results
     
    ##- Please type your reply above this line -##

    Your request (#289351) has been solved. To reopen this request, reply to this email or click the link below:
    https://tickets.oculus.com/hc/requests/289351

    Hannah

    Hannah (Oculus Support)

    Dec 12, 2:09 PM PST

    Hi Corey,

    Thanks for reaching out and sorry for the delay in our response. When did you receive the test results that you listed below? I just took a look at your test results and it looks like the only things our QA team caught were the frame rate issues and also an entitlement issue. Here are the notes that they left regarding your app:

    "It appears that your app does not support entitlement checks to prevent unauthorized use of your content."
    You can find documentation on how to add entitlement checks here: https://developer3.oculus.com/documentation/platform/latest/concepts/dg-core-content/#dg-cc-entitlements

    "Your app should maintain a frame rate of 90 FPS most of the time. Frame rate is consistently around 30 - 50 FPS during video playback."
    We can only pass an app that maintains 90 FPS throughout the entire app experience. Unfortunately they did not leave notes when this specifically occurred. Regardless of where it was identified, please make sure that frame rate is met throughout the entire app experience.

    Hopefully this helps, but let me know if anything else comes up.

    Thanks,
    Hannah
    The Oculus Store

    corey jans

    corey janssens

    Dec 7, 12:26 PM PST

    "We were unable to complete testing due to progression blockers. There's no way to navigate to a different source video folder while in the experience. Videos have to be in the Videos folder for them to be viewable."
    The Oculus vid player pulls from the video file (aside from streaming). So what the hell do you guys want? Do we need folder source options?>
    We need this answered today. If you can't answer this today, then we'll start on our vive development and get back to the oculus when ever.

    corey jans

    corey janssens

    Dec 5, 5:15 PM PST

    Hi Oculus Support,

    I received initial test results back on my app submission for Voyeur VR. The test says it failed on six items and I wanted to get a little more information on some of the reasons and solutions.

    1. Your title takes a long time to render in Skyline or Home. Cannot launch the app from Oculus Home because of a configuration window that appears on the desktop. Launches with a configuration window, preventing the app from booting directly from Skyline or Home.

    - Is there a way I could get a screenshot of this occurring? Since I was testing by sideloading the app, a configuration window showed up asking for screen resolution. I assumed this was because of the app being sideloaded. I would just like to check and see if it's the same window so I can disable it.

    2. We were unable to complete testing due to progression blockers. There's no way to navigate to a different source video folder while in the experience. Videos have to be in the Videos folder for them to be viewable.

    - We have the app set so users put the videos in their videos folder and watch them from there. I'm a little confused on the requirements of this fail. Are we required to have users select videos from anywhere? The video players currently on the Oculus show videos from the videos folder. Is there another folder we're needing to select from?

    3. Your app should maintain a framerate of 90 FPS most of the time. Frame rate drops down to around 60 during video playback.

    - We should be able to look into our settings on the video player for this. Do you have any information on the type of videos you tested this out on so we can look into settings? Specifically video size, length, and resolution.

    When I'm submitting the update to the store, are the steps the same as the initial submission?

    Thanks,

    -Corey

    This email is a service from Oculus Support. Delivered by Zendesk.
    [JPEK9O-K46D]

  • cbsilvacbsilva Posts: 1
    Virtual Boy (or Girl)
    edited December 2016
    Por favor liberem o app litchi para samsung vr engrenagem
  • RakkuAmiyaRakkuAmiya Posts: 63
    Hiro Protagonist
    Just a quick question... I was hoping to submit my bird simulator for review, but it's been sat on Malware review for about 4 hours now.  Would you know how long it normally takes?  My project isn't even that big, at 1.8gb and most of that is textures.  I'm just wondering if I need to run it overnight.  The check is on Internet Explorer 11 on Windows 10.  I went for IE just incase Edge screwed something up, which it did while trying to upload the preview video.

    Thank you.. :)

    Graeme
  • redwhiteca_serdarredwhiteca_serdar Posts: 12
    Virtual Boy (or Girl)
    Is there something wrong with the submissions? Our test build is waiting on the malware review for hours too. This is the first time we got this review process running.
  • ChiselyChisely Posts: 1
    Virtual Boy (or Girl)
    Have a similar problem here.

    I see an error that says "Upload Your Build. Please allow build testing to complete." om the submit page. I have a build on STORE channel and its Test Status says "Complete" with a blue dot. Is this a bug or there is something I'm missing?
  • MickyXMickyX Posts: 43
    Lawnmower Man (or Woman)
    Are you able to upload a free demo game with say a few single player missions and a full price version to the store?
  • KristopherKip.KristopherKip. Posts: 1
    Virtual Boy (or Girl)
    Help.  I purchased the Oculus Rift for my son from Microsoft for Christmas and his new gaming pc arrived yesterday.  We tried to enter the $100.00 Oculus Store Credit but it doesn't follow the format of your Redeem Code and it will not work.  I spoke with Microsoft and they directed me to you.  Some assistance please.
  • juanoldinhojuanoldinho Posts: 54 Oculus Staff
    KristopherKip. said:
    Help.  I purchased the Oculus Rift for my son from Microsoft for Christmas and his new gaming pc arrived yesterday.  We tried to enter the $100.00 Oculus Store Credit but it doesn't follow the format of your Redeem Code and it will not work.  I spoke with Microsoft and they directed me to you.  Some assistance please.
    Hi,

    Can you file a ticket here: 

    https://tickets.oculus.com/hc/en-us/requests/new

    They should be able to assist you.
  • hitechhitech Posts: 9
    Virtual Boy (or Girl)
    Hello,

    My product Aces High has passed all test, except it occasionally drops below 90 in high density areas when low to the ground.

    Aces High has been online for 18 years. Making a change in the view distant or detail to maintain 90 is not an option due to the number of players who also play in Non VR.

    Many customers are already using VR simply not from threw the store. Is there any way for it to be approved with the current test results?

    Or is it possible to simply raise the requirements 980 instead of 970? Thanks.

    Thanks
    Dale
  • ssc_mikessc_mike Posts: 5
    Virtual Boy (or Girl)
    Hey, welcome to the new Store Submissions forum!
    I really have to give you a praise for opening this one on here! Neither Apple nor Google has submission forum but I guess they well beyond early adopters. It keeps the spirit up!
  • tansbeydelrtansbeydelr Posts: 1
    Virtual Boy (or Girl)
    Congrast!
  • MAC_MAN86MAC_MAN86 Posts: 41
    Lawnmower Man (or Woman)
    edited March 4
    Description
    Today's Oculus Runtime Update v1.12 as now totally ruined the game. It now stutters every second even when using hotkeys to DISABLE ASW which worked 100% smooth previously in v1.11 and previously we even heard a Sound Confirmation when we switched these Modes but there is none now. I know it still switches as I can see a difference from CTRL&Numpad1 when compared with auto CTRL&Numpad4. I do know for a fact this is NOT reverting back to the original game mode.

    This is SEVERE AND SORRY FD - I CAN NOT PLAY ELITE:DANGEROUS ANYMORE until fixed as before. It isn't even you problem but is that of OCULUS for altering this. I also read other users have issues with other games.


    Steps to Reproduce
    Rebooted - all I will try next is to swap over the USB sockets to rebalance them. This has worked for 1 user.

    WHY?

  • MAC_MAN86MAC_MAN86 Posts: 41
    Lawnmower Man (or Woman)
    PROBLEM FIXED! - by going into Oculus Home Settings on monitor and simply using the RESTART OCULUS (for me this is in the BETA MENU at the bottom of the list as I must use v1.3.2 to avoid the SSE4.2 cpu check).
    Happy to play once again ;)
  • iristavriristavr Posts: 6
    Virtual Boy (or Girl)
    How long does it usually take for a submission to be reviewed after initial submission. I have seen reports of two weeks but this was from mid 2016. Can you share some up to date timescale figures? Thanks!
  • MickyXMickyX Posts: 43
    Lawnmower Man (or Woman)
    edited April 5
    VAT Registration Question.

    I was hoping to submit my app to the store as a Individual. In admittedly limited understanding I do not have to be VAT registered unless 
    • your VAT taxable turnover is more than £85,000 (the ‘threshold’) in a 12 month period
    • you expect to go over the threshold in a single 30 day period
    However the submission page has a mandatory VAT registration number. Is there a way to submit the app without a VAT number or do I need to setup a VAT registered Company before I can submit?

    Thanks in advance
  • MurriouzMurriouz Posts: 1
    Virtual Boy (or Girl)
    edited April 14
    Hi,

    How can I add icon to show in oculus home? Like the red rect in attached screecshot.

    I'm using Unity and Oculus GearVR Unity SDK.

    Device: Samsung Note 5 and Gear VR

    Thanks.


Sign In or Register to comment.