/ Forums
Applications are now open to attend this year's Oculus Connect. Join us October 11–12 and be first in line for an inside look at what’s new and next for VR.

Oculus Connect 4: Speaker Preview

We've revealed some of the Oculus speakers who'll present at Oculus Connect 4 this year! Click here to learn more.
New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

How to make hands and controllers appear in EXE

dr3ddr3d Posts: 5
Virtual Boy (or Girl)
Using Unity 5.5, I've no problem seeing hands and controllers for the demos and anything I make using Avatar SDK when previewed in the Editor. But if I build Win10 executables, I don't see any avatar parts. Am I missing something?

Best Answer

Answers

  • digibixdigibix Posts: 6
    Virtual Boy (or Girl)
    You have to include the OVRAvatars/Content/Materials  ... shaders (there are 3) on Project Settings... Graphics.... Alwalys include Shader option......
  • WickedManateeWickedManatee Posts: 22
    Lawnmower Man (or Woman)
    Tried and this worked for me, thanks digibix!
    (the shaders are AvatarSurfaceShader, AvatarSurfaceShaderPBS, AvatarSurfaceShaderSelfOccluding)
  • BretonBreton Posts: 83
    Hiro Protagonist
    edited December 2016

    Sorry to say this do not work for me. :'(

    I have tried loading all the Avatar...shaders into both Player" and "graphics" like this post suggest, but i still get this log running my compiled exe(i have installed unity and made a new Project. only loading the assets below)

    Unity v5.5.0f3,   

     Oculus Utilities v1.10.0,  

    OVRPlugin v1.10.0,  

    SDK v1.10.1 

    Oculus Avatar SDK V1.10.1


    OVRManager:Awake() (at E:\unity proj - CV1\Assets\OVR\Scripts\OVRManager.cs:548)
     
    (Filename: E:/unity proj - CV1/Assets/OVR/Scripts/OVRManager.cs Line: 548)

    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/libovravatar
    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/.\libovravatar
    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/libovravatar
    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/libovravatar
    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/.\libovravatar
    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/libovravatar
    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/libovravatar
    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/.\libovravatar
    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/libovravatar
    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/libovravatar
    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/.\libovravatar
    Fallback handler could not load library C:/Users/e/Downloads/Ny mapp/ny_Data/Mono/libovravatar
    DllNotFoundException: libovravatar
      at (wrapper managed-to-native) Oculus.Avatar.CAPI:ovrAvatar_Initialize (string)
      at OvrAvatarSDKManager.Initialize () [0x0002f] in E:\unity proj - CV1\Assets\OvrAvatar\Scripts\OvrAvatarSDKManager.cs:43
      at OvrAvatarSDKManager.get_Instance () [0x00048] in E:\unity proj - CV1\Assets\OvrAvatar\Scripts\OvrAvatarSDKManager.cs:28
      at OvrAvatar.Start () [0x00019] in E:\unity proj - CV1\Assets\OvrAvatar\Scripts\OvrAvatar.cs:433  

  • GravedrinkerGravedrinker Posts: 2
    Virtual Boy (or Girl)
    Doesn't work for me either. I included the shaders, but running the exe is missing the hands/controllers, just as before.
  • MikeFMikeF Posts: 283
    Art3mis
    Try moving the shaders to your resources folder before building, also be sure to change the cg shader path reference in each shader (should be at the bottom)
  • haskinshaskins Posts: 27
    Lawnmower Man (or Woman)
    Similar problem.. I can see the shaders in the editor but when I make a build, I can't see localavatar or anything that seems to use the shaders.

    I've added the shaders into the Resources folder, and to the list in graphics settings.  I've changed the paths in the shaders to #include "Assets/Resources/AvatarMaterialStateShader.cginc"

    Seems like it should be easier to implement, maybe I'm missing something obvious? Any advice is welcome. 

    Unity v5.4.3xEditorVR-p3, Oculus Utilities v1.10.0, OVRPlugin v1.10.0, SDK v1.10.2.
    UnityEngine.Debug:Log(Object)
    OVRManager:Awake() (at Assets/OVR/Scripts/OVRManager.cs:548)

  • haskinshaskins Posts: 27
    Lawnmower Man (or Woman)
    Thanks Breton, that was the last piece of the puzzle for me. I'm seeing the shaders render in a build!
  • BrandonW6BrandonW6 Posts: 1
    Virtual Boy (or Girl)
    Thank you!
  • jarekdcjarekdc Posts: 1
    Virtual Boy (or Girl)
    switching to x86_64 architecture fixed it in our case, thanks!
  • TrustyzTrustyz Posts: 1
    Virtual Boy (or Girl)
    Shader + x86_64 works here, thanks !
Sign In or Register to comment.