/ Forums
New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

IAP - Error OVR77152342 after calling API ovr_IAP_LaunchCheckoutFlow with no useful error message

ghostblade1982ghostblade1982 Posts: 4
Virtual Boy (or Girl)
edited March 20 in Platform SDK Development
When calling API ovr_IAP_LaunchCheckoutFlow(const char* sku)
I get the following error message:

[QueueAsyncResponseHandler] failure: OVR77152342

No further information to help debug this issue.

In the function doc, it says:
/// Launch the checkout flow to purchase the existing product. Oculus Home
/// tries handle and fix as many errors as possible. Home returns the
/// appropriate error message and how to resolveit, if possible. Returns a
/// purchase on success, empty purchase on cancel, and an error on error.

However, as you can see the error message provided no information on how to resolve it.

Comments

  • ghostblade1982ghostblade1982 Posts: 4
    Virtual Boy (or Girl)
    edited March 20
    Anyone seen this error before?

    Some additional info: other IAP API calls are successful such as ovr_IAP_GetProductsBySKU(), so I'm assuming the app setup and Oculus platform SDK and runtime SDK are correctly setup. consumable items are correctly uploaded to my App store.

    I'm modifying the Sample app 'NativeSample' to test the purchase.
  • imperativityimperativity Posts: 851 Oculus Staff
    Hi,

    I am currently looking into this issue and will advise you on what next steps need to be taken.

    Thanks for your patience.
  • imperativityimperativity Posts: 851 Oculus Staff
    Hi,

    After looking into your application it looks like you have no payment info entered for your org. This may be your issue. Can you update this with the relevant information and try again?

    Thank you.
  • ghostblade1982ghostblade1982 Posts: 4
    Virtual Boy (or Girl)
    hi, I did setup the organization payment method on the Payment Info tab of my organization page.  After clicking 'submit', the first 5 digits of routing number were masked as '*', while the account number became the last 4 digits of the account number I input. I input the information again and the problem still persists 
  • imperativityimperativity Posts: 851 Oculus Staff
    OK--thanks for checking.

    That is standard procedure for with the last 4 digits being shown of the account number.

    We are digging into this issue on our end right now and will have an update for you soon.
  • ghostblade1982ghostblade1982 Posts: 4
    Virtual Boy (or Girl)
    Thanks for looking into this. Any updates?
  • imperativityimperativity Posts: 851 Oculus Staff
    @ghostblade1982

    Responded to your pm.
  • ReboundGamesReboundGames Posts: 1
    Virtual Boy (or Girl)
    Any public information regarding this error? What does the error message mean and what would be the solution to this?

    I'm running into the same situation, without clear instructions on what to do next. The payment details are set up for my organization correctly.
  • imperativityimperativity Posts: 851 Oculus Staff
    @ReboundGames

    This is an internal issue we are currently working to fix at this time. We are working on updated documentation, best practices in using IAP and how to diagnose and fix these errors. There will be more information about this coming in the near future.
Sign In or Register to comment.