/ Forums
Applications are now open to attend this year's Oculus Connect. Join us October 11–12 and be first in line for an inside look at what’s new and next for VR.

Oculus Connect 4: Speaker Preview

We've revealed some of the Oculus speakers who'll present at Oculus Connect 4 this year! Click here to learn more.
New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Crash Reports From Users : VR: Error setting active audio output driver. Falling back to default.

FallenPlanetFallenPlanet Posts: 73
Hiro Protagonist
We have had a number of reports of AFFECTED crashing on load. We have isolated the issue to be an Audio Driver problem but are having difficulty in A) Replicating the issue and B) Fixing the issue.

I have attached one of the crash dumps for someone more knowledgeable to look over.

Any help would be massively appreciated,

Mark

Using:
Unity v5.5.1f1,
Oculus Utilities v1.10.0,
OVRPlugin v1.10.0,
SDK v1.12.0.

Affected - The Horror Experience - DK2 Now OUT! Download on Oculus Share
http://www.fallenplanetstudios.com

Comments

  • imperativityimperativity Posts: 1,192 Oculus Staff
    Hi,

    I am currently looking into this and will advise you on what information I find that is applicable to your situation.
  • imperativityimperativity Posts: 1,192 Oculus Staff
    Your version of Unity is not compatible with your version of Oculus Utilities. Ideally, Unity version 5.5.1p2  or 
    5.5.2p3. This should solve your issue with the audio driver failing.

    Please review the compatibility chart found in the link below:

    https://developer3.oculus.com/documentation/game-engines/latest/concepts/unity-sdk-version-compatibility/
  • FallenPlanetFallenPlanet Posts: 73
    Hiro Protagonist
    Hey Imperativity

    We have tried Unity 5.5.1p2 with Utilities 1.10 and the issue persists with the audio driver. We have also tried 5.5.2p3 with Oculus Utilities 1.12 and Oculus Platform 1.12.1 but now the game crashes on load. Also in 5.5.2p3 the frame rate seems severely hampered in editor compared to 5.5.1p2.

    Can you advise which Utilities and Unity build you are classing as the most stable?
    Thanks
    Affected - The Horror Experience - DK2 Now OUT! Download on Oculus Share
    http://www.fallenplanetstudios.com
  • imperativityimperativity Posts: 1,192 Oculus Staff
    Hi,

    I'm going to dig into this issue some more and get some more answers for you.

    Please reference the unity compatibility chart at the following link for ideal unity versions paired with our integration and SDKs here (unity 5.5.2p3 is also compatible with 1.12 but is not shown):

    https://developer3.oculus.com/documentation/game-engines/latest/concepts/unity-sdk-version-compatibility/

  • imperativityimperativity Posts: 1,192 Oculus Staff
    edited March 22
    5.5.2p3 + 1.12 should be one of the most stable configurations.

     Can you provide  a profiler snapshot from the slowdown?

    edit: can I also get an updated output_log crash file for the Unity 5.5.2p3 and Oculus Utilities 1.12 combo?
Sign In or Register to comment.