/ Forums
New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Spatial Blend in Unity not working

jlinkjlink Posts: 16
Virtual Boy (or Girl)
We recently updated our project to Unity 5.5.2 (from 5.5.1) and it seems like the spatial blend setting for audio sources stopped working on our Oculus spatialized sounds.

We're dynamically generating audio sources from preset data and all of our settings are getting applied to the audio sources from what I can tell, but for whatever reason the spatial blend doesn't seem to be working anymore. On the sources in question, we're setting spatial blend to 0.5 for a mix of both 2D and 3D spatialized audio. However, when out of range of the source (a couple meters) the audio can't be heard at all. I did go through our code that instantiates the audio sources to make sure that we're setting the source's parameters with ONSPAudioSource's SetParameters method, but that didn't solve our issue.

Did the Oculus audio plugin for Unity stop supporting spatial blend settings, is this a bug, or am I missing something else?

Comments

  • PeterStirlingPeterStirling Posts: 91 Oculus Staff
    Hi jlink,

    I'm not sure about the status of spatial blend because it's not a feature we use or test internally. I don't think we have done anything on our side to break it but I could be mistaken.

    Stepping back a bit I'm curious to understand how/why you're using this feature, as there may be a better approach. Spatial blend does not work well with 3D audio because a integral part of the HRTF is the inter-aural time difference (ITD), which is the delay from one ear to the other. Given the original mono signal will not have any delay, when mixing them together it will result in comb filtering which is not desirable. The ITD varies based on the angle the sound is coming from so it will be like a phaser effect when the listener turns their head.
Sign In or Register to comment.