/ Forums
New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Disable function in Oculus Home and also NOT cap all the fps to either just 45 or 90

MAC_MAN86MAC_MAN86 Posts: 52
Lawnmower Man (or Woman)
Disabling ASW (CTRL+Numpad1) does not stop ASW from capping to 45fps. It simply removes the extra added frames.
I see mine wander about 80 to 90 in menus but in the game it is capped down to 45fps and wanders down to 30fps in RES and Stations.
ASW is to make the frames more smoother and regular so it can then add the frames between. If it was jumping always between 45-90 then it would need to calculate each different half-frame and would be more process. When this figure is a known number it applies the added frame efficiently.

Unfortunately, it was intended to cater for slower systems but on most other than i7 it simply does not work with fast action 360 movement games (ED and Project Cars).

It therefore should have a Disable function in Oculus Home and also NOT cap all the fps to either just 45 or 90. We are being robbed our full potential. Although 45 is very good indeed. If only it was 45 for RES & Stations also!

Comments

  • MAC_MAN86MAC_MAN86 Posts: 52
    Lawnmower Man (or Woman)
    The above refers to playing within Elite:Dangerous for reference.
  • imperativityimperativity Posts: 972 Oculus Staff
    Hi,

    Just to give a little more context on this:

    We always display exactly 90 frames per second on the HMD. If the app renders that fast, then that's what we show. If the app renders at 60fps, every 3rd frame is being corrected by ATW, which causes visible stuttering. Instead of doing that, we drop the app back to 45fps and use ASW to fill in every 2nd frame. If the app ever starts rendering fast enough for 90fps again, ASW turns off.

  • MAC_MAN86MAC_MAN86 Posts: 52
    Lawnmower Man (or Woman)
    OK so this explains why I see it drift from 60 to 85 in the System Map of Elite. Then why I get it capped for the rest of the game at 45 but it dips to ~30 in the Stations and at RES places. So how about we could Disable ATW (or is that not yours?) but definitely Disable ASW by an Option in Home? Only i7's are getting a constant 90 and they even benefit with ASW they say. It's not supposed to be for fast Systems yet it seems it is.
    So far I need Home to remember Defaults for Affinity + Disable ASW and then it's fixed almost.
Sign In or Register to comment.