New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Bug with the OculusSpatializer using Unity 5.5.0 and Wwise 2016

AudiogamingdevAudiogamingdev Posts: 6
NerveGear
Hello,

As it says in the title we have a very weird bug with the Oculus Spatializer for Wwise. Indeed, the binaural is working well in Oculus as long as I don't activate any Oculus attenuation. As soon as I activate one (no matter which one) the binaural effect is broken completly (not only for the one that has the attenuation).

The weirder part is that it works fine on my regular headphones, linked to my soundcard, if I select the output to be "Windows by default" on the Oculus software.

Someone experienced this? Any ideas?

Thanks!

Comments

  • PeterStirlingPeterStirling Posts: 116 Oculus Staff
    Hi Audiogamingdev,

    There are a few confounding factors there so it's hard to isolate what the problem is there but I can take a guess. It sounds like the attenuation is the main factor here. The oculus attenuation will only reduce the gain of the signal spatialized signal.

    My guess is that you have a unspatialized signal path, (e.g. using the spread parameter or a send to reverb). When you turn on the attenuation it is reducing the level of the spatialized signal and changing the wet/dry ratio of spatial:non-spatial, making it sound like it's not being spatialized at all.

    Something to keep in mind when using oculus attenuation in Wwise is to _remove_ the attenuation shareset, otherwise it will be attenuated twice and close to silent. It's also worth noting that the oculus attenuation curve falls off more sharply so it can seem like it's quiet compared to authored curves. Adjust the Attenuation Range Max to make sounds more audible in the distance.
  • AudiogamingdevAudiogamingdev Posts: 6
    NerveGear
    Hello Peter,

    Sorry, maybe it wasn't too clear, here are some screenshots so you can see the overall setup we have inside Wwise :

    The overall 3DSound group, no child overides that :


    We have this in our effects :



    The weird bug is gone, probably something caused by a bad detection of the device but I still have no attenuation I tried to change the values in Wwise and it's exactly the same, but we do have binaural working fine.

    Thanks!
  • PeterStirlingPeterStirling Posts: 116 Oculus Staff
    edited May 18
    The metering effect might be interfering with the spatializer plugin, this is something we saw on one of our internal projects. It's a quirk of the Wwise system that having additional effects causes Wwise to bypass our spatializer and fall back to panning. It does this without reporting any warnings or errors. I expect that is what is happening here.
  • AudiogamingdevAudiogamingdev Posts: 6
    NerveGear
    Thanks for the answer, I deleted it for the test and it didn't change anything.

    I think I "figured it out" tho, I have cars who are under an actor mixer who were not attenuated at all while a Carousel loop who was just a regular sound with actual attenuation settings (not taken from parent) worked just fine. It looks like I have to actually tell each sound to be attenuated and Wwise doesn't care if I only put the attenuation settings on the actor mixer and tell him to keep the same setting for every sound inside.

    Does this seem possible? It looks like it worked but I find it strange.
  • pgiokarispgiokaris Posts: 5 Oculus Staff
    Hi there,

    Could you let us know which version of the spatializer and which version of Wwise you are using?

    I have tested our current version of the plug-in (note: we will be releasing 1.1.5 shortly which has extra functionality for previewing all spatializer parameters within the plug-in, including 3D positioning with the positioning tool). I can confirm the following:

    If a child sound (or other actor/mixers) does not override its parent, it will get all of the spatializer settings from the parent actor/mixer it is assigned to, including attenuation settings. Therefore, if you want different settings for each sound underneath the 3D actor/mixer, you will need to override its Mixer-plugin settings to do that (like you did with the Carousel loop).

    There is a level of flexibility here that comes from this: If you desire to have a group of sounds sharing the same spatializer settings, simply create a new actor/mixer, assign the sounds to this new node (do not override parents on the sounds) and then override the spatializer settings on the new actor/mixer. It will still be contained under the master 3D actor/mixer (which is assigned to the 3D bus) but will have independent spatializer settings for that branch of sounds.

    I've added an image that shows which nodes in the hierarchy override the main actor-mixer. Set 1 controls all the spatializer settings for everything underneath it. Set 2 does not override, put the sound underneath it does.

    Hope this helps..

    Peter


  • AudiogamingdevAudiogamingdev Posts: 6
    NerveGear
    edited May 22
    Hi,

    Thanks for the answer. It's very weird, maybe I do something wrong or I have a wrong version problem because I confirm that for me if I don't override every child they are not touched by the attenuation.

    My versions :

    Wwise is 2016.2.1 and AudioSDK is 1.1.4
Sign In or Register to comment.