New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Why does my gameObject's mesh edges were flickering in Oculus?

NirmlRjNirmlRj Posts: 6
NerveGear
Hello Guys, I am making a quite big world for my game in Unity for Oculus Rift. Initially when I tried my game with default settings it looked somewhat blurry and mesh edges were flickering like a hell (especially trees). So I changed RenderScale value to 2 from 1. It made huge difference in my game quality but FPS went below 60 and then I adjusted RenderScale value to 1.2 so now my game quality is okay and FPS is also okay. But the problem I'm facing now is the flickering in mesh edges. I even tried with 8x MSAA but still flickering exists. Does anyone know how to solve this. FYI : THOSE FLICKERING PROBLEM IS ONLY IN OCULUS SCREEN, PC MONITOR DOES NOT SHOW THAT MUCH FLICKERING

Oculus Version : Oculus Rift CV1

Current Settings :  Rendering Path -> Forward,  AA -> 8x MSAA, VSync -> Disabled, Color Space -> Gamma, Stereo Rendering Method -> Single Pass. 

PC Specs : RAM -> 32GB, Processor -> Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz 4.00 GHz,  Gfx -> NVIDIA GeForce GTX 1070

If you guys need additional Info, I will provide :smile:
 

Answers

  • moonbearmoonbear Posts: 36
    Brain Burst
    Does your camera also have "Forward" as the rendering path? Sometimes it might override "Player Settings".
  • NirmlRjNirmlRj Posts: 6
    NerveGear
    moonbear said:
    Does your camera also have "Forward" as the rendering path? Sometimes it might override "Player Settings".
    Yes. I always check it before playing game in editor and before taking build.
Sign In or Register to comment.