/ Forums
Applications are now open to attend this year's Oculus Connect. Join us October 11–12 and be first in line for an inside look at what’s new and next for VR.

Oculus Connect 4: Speaker Preview

We've revealed some of the Oculus speakers who'll present at Oculus Connect 4 this year! Click here to learn more.
New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

The Windows SDK version 10.0.10586.0 was not found

brlibrli Posts: 1
Virtual Boy (or Girl)
I was following the PC SDK getting started guide, and progressed relatively smoothly until I tried to run the demos in the samples file Samples/Projects/Windows/VS2015/Samples.sln in Visual studio 2015.

I encountered the error "The windows sdk version 10.0.10586.0 was not found." I followed the steps to correct it in the guide as well: I followed the instructions: edit Project Properties → General → Target Platform Version and changed the version to 10.0.15063.0, which was the windows 10 SDK on my computer.

However, with this, the same exact error remained, "The windows sdk version 10.0.10586.0 was not found." So I went even farther, going into the Windows10SDKPaths.props file, and changed all 6 instances of 10.0.10586 to 10.0.15063. However, the same exact error popped up once again. I've tried closing Visual studio and restarting my laptop between steps, however, the result is still the same.

Can you please advise on how to fix this? Thanks in advance.

Comments

  • imperativityimperativity Posts: 1,172 Oculus Staff
    Hi,

    Welcome to the Oculus Developer Forums.

    I was able to successfully run the 1.16 PC SDK Samples.sln in VS2015.

    I was also able to build the solution with both 8.1 and 10.0.15063.0 target platforms successfully as well.

    If you were to reinstall VS2015 and the windows SDK again, does this problem persist? If so, does this problem continue if you were to use another computer?

    Please advise.
  • neilsarkarneilsarkar Posts: 3
    Virtual Boy (or Girl)
    I also had this identical issue with the VS2017 community edition that is installed automatically when you install the oculus SDK.

    Just uninstalled VS2017, I'm downloading VS2015 update 3 from https://my.visualstudio.com/Downloads?q=Visual Studio 2015 with Update 3 and will let you know if I can still reproduce this issue.
  • ConstellationConstellation Posts: 179
    Art3mis
    When I switched the target platform with VS 2017 Community it didn't change all the version strings in my .vcxproj file. I closed VS, edited the file manually and then I was able to get it to build.
Sign In or Register to comment.